Old pc game from 2000 doesn't start in Windows 10

Latest News & Videos

Red Arrow

ça va nog wel
Hello everyone :)

Today I tried to install Donald Duck Quack Attack. (It is called Goin' Quackers in the US)
The installation was easy, everything worked like it should, but then I tried to start the game and I just got a white screen with "Donald Duck" in the upper left corner.

The game worked just fine on Windows XP.

Someone asked the same question in a German forum, but for Windows 7. They told him/her that you have to turn on a Compability Mode. Does anyone know how this works for Windows 10?

EDIT: I have tried the compability mode for Windows 98, XP (Pack 2) and XP (Pack 3) and none of them worked :(
 
Last edited:

Red Arrow

ça va nog wel
It didn't work, but thanks for replying.

I have checked the cd-rom box and my laptop fits all system requirements. It should work in one way or another.
 

Red Arrow

ça va nog wel
A Russian YouTuber told me I had to download DirectX 12. I couldn't find any legal dowloads but I did find this on Microsoft's website. It's for DirectX 9.

It works now :) Yeey!
 

Red Arrow

ça va nog wel
Well, I can't help you with downloading... It should be straightforward :sweat: You can try downloading it with compatibility mode on?

-----------------------------------------------------------------------------------------------------------------------------------------------------------------

You need to download DirectX 9, 10, 11 or 12 and turn on the compatibility mode for Windows XP or Windows 2000.

DirectX 9 on microsoft.com (it's legal and free)
https://www.microsoft.com/en-us/dow...02X558040X47a9805c5a3e4e1c68e3ebc9f3e2fad2)()
(286 kilobyte in total)

Compatibility mode:
Right mouse button => Properties => Compatibility => "Run the program in compatibility mode for:"

Choose Windows XP or Windows 2000.

When you want to defeat the second boss (the Beagle Boys), do not wear the vacation costume! The game will block completely. You need to play this level with the original costume. You can use Gyro Gearloose's machine to change your costume.
 
Last edited:

bistoboy

New Member
Thanks for the reply! It says that alredy have that version of DX9 (or higher) installed. and just wondering is your laptop a 32 bit OS as I think my 64bit pc is the problem as the CD launchers the first pop up, I click install and it just closes creating a background task called "32 bit setup launcher" and nothing happens
 

Red Arrow

ça va nog wel
Google is your friend:

I had this exact problem earlier, I solved it by closing a program that was blocking the installation from continuing.

Solution: go to Task Manager, on the details tab, right click on setup.exe and 'analyze wait chain', this may show you the program that is blocking the installation from continuing. In my case it was Evernote, I closed it and it worked again.

Step by step instructions + Screenshots
Source: Reddit (link)
 

bistoboy

New Member
yh thanks for the help I did find the same reddit thread lol, but now I get error 103 cant find _setup.dll which I think is a compatibility issue that I cant solve, im gonna try running on a virtual machine instead, thanks any way!
 

Similar threads

Spotlight

Staff online

Latest profile posts

Oh, the irony - while foreign feeds of Cartoon Network ban just about anything, CN USA started to show Shrek completely uncut - with the "offensive" words intact - in 2017! Around the time when Cartoon Network feeds worldwide were already ruled by the nanny state!
Don't ever force yourself into liking a show or any other form of media and don't be afraid to speak up about how you honestly feel about it. Anything can be improved, especially with criticism.
NeoplanDan wrote on Zedd's profile.
Hi, Zedd, I wanted to to fix up the date on my birthday, when I was first registered here, it incorrectly date as 1/21/1995 when it actually 2/21/1995, originally I was going to ask one of the admins to fix it so that it’s on the correct date.
I'm the best anime character. You will all bow down to me.
Well, THAT was a flop...Adventure Time will leave Adult Swim after two weeks...
Top